Difference between revisions of "Developer FAQ"

From Event-B
Jump to: navigation, search
m (I have compilation errors after having checked out the org.eventb.core.seqprover plug-in, what shall I do?)
m
Line 142: Line 142:
  
 
r1. The classes are not generated properly although the project was build.<br>
 
r1. The classes are not generated properly although the project was build.<br>
'''Solution''' : Right-click on the build-tom.xml file and select "Run As... > Ant Build".
+
'''Solution''' : Right-click on the build-tom.xml file and select "Run As... > Ant Build". Sometimes it is also necessary to refresh: right-click the project and select "Refresh".
  
 
r2. The solution of 1 didn't work and I still have some errors in the plugin.xml file. (You will have to force the plugin.xml resource refreshing)<br>
 
r2. The solution of 1 didn't work and I still have some errors in the plugin.xml file. (You will have to force the plugin.xml resource refreshing)<br>

Revision as of 09:22, 30 March 2011

How to contribute?

What are the main community channels?

Beside the mailing lists, you may want to follow:

The Village Pump may also be useful for everything which is more or less wiki related.


How do I report a bug or a feature request?

You may use sourceforge bug and feature tracker. Please verify that your bug has not already been reported before submitting it.

You may want to submit a partial or full log which you can find in the following file
.metadata/.log
under the rodin workspace (generally
runtime-Rodin.product/
).

How do I get current source code?

You may get the whole Rodin Platform and most of associated Rodin Plug-ins from Subversion on SourceForge using URL https://rodin-b-sharp.svn.sourceforge.net/svnroot/rodin-b-sharp.

To compile the core platform from sources fetched from Subversion, download the latest stable version of Eclipse Classic and install the Subclipse plug-ins. Then, follow this procedure to fetch the source plug-ins from Subversion:

  • click File>Import...
  • select SVN>Checkout Projects from SVN and click Next
  • tick Create a new repository location and click Next
  • in the Url field, enter https://rodin-b-sharp.svn.sourceforge.net/svnroot/rodin-b-sharp and click Next
  • after a while, a tree appears. Select folder trunk/RodinCore/org.rodinp.releng in the tree and click Finish
  • click File>Import...
  • select Team>Team Project Set and click Next
  • click Browse... and select file rodin-core.psf in project org.eclipse.releng, then click Finish

After a long while (around a quarter of an hour), all projects of the core Rodin platform have been retrieved from Subversion into your workspace.

You can retrieve the test plug-ins of the core platform in a similar way by repeating the last three steps but selecting file rodin-tests.psf instead.

Note: The repository was formerly CVS which is still available read-only. It is not possible to commit to the CVS repository anymore. More information is available in the Switch from CVS to Subversion page.

How do I launch the Rodin Platform from Eclipse?

Normally, you should be able to launch the Rodin Platform by launching Rodin.product in org.rodinp.platform as an Eclipse application. At the time of writing (June 11, 2009), the platform crashes, because not all the required plug-ins are included.

A workaround is to include all workspace and enabled target plug-ins in the run configuration:

  • go to run -> run configurations
  • select the newly generated run configuration
  • go to the tab "plug-ins"
  • Choose: "launch with: all workspace and enabled target plug-ins in the run configuration"

How can I access or create Rodin elements like projects, components or proofs?

This section illustrates some of the things you are likely to want to do in your plug-ins if you are extending the Rodin platform.

How do I propose a patch?

You may find useful directions and good practises in the page describing how to submit patches.

Developer FAQ

How can I get the sources of the Rodin platform?

There are two options for getting the sources of the Rodin platform:

  1. The safe option is to download the source bundle which is made available with each platform release. This ensures that you will get a consistent set of source files, albeit maybe a bit outdated.
  2. The other option is to fetch the sources from Subversion, which allows to get their latest version. The Rodin developers strive for keeping theses sources usable (i.e. they should always compile and pass unit tests), but breakage can happen.

Installing the source bundle in Eclipse

To install the bundled sources, you first have to download the bundle from SourceForge. It takes the form of a ZIP file named rodin-VERSION-sources.zip. Then, in Eclipse, click File > Import... In the Import popup, select General > Existing Projects into Workspace and click Next. Then tick Select archive file and enter the path to the source bundle you have just downloaded. Ensure that all projects are ticked and click Finish. Your workspace gets populated with the source projects of the Rodin platform and Eclipse starts building.

Installing the sources from Subversion in Eclipse

To install the sources from Subversion, in Eclipse click File > Import..., then select SVN > Checkout Projects from SVN in the Import popup and click Next twice. In the Url textbox, enter https://rodin-b-sharp.svn.sourceforge.net/svnroot/rodin-b-sharp and click Next. In the tree displaying the subversion repository, select path trunk/RodinCore/org.rodinp.releng and click Finish. Your workspace now contains the project org.rodinp.releng.

To install the other source projects, click again File > Import..., but this time select Team > Team Project Set and click Next. When asked for a File name, enter the path to file org.rodinp.releng/rodin-core.psf in your workspace and click Finish. Eclipse then fetches the other source projects of the Rodin platform into your workspace (this can take some time).

Using Rodin as Target Platform

From Rodin 1.3 on, source bundles can be included in a target platform configuration.

Using Rodin-SVN from Eclipse consumes too much memory

Running the Rodin platform from Eclipse can consume a lot of RAM and become impractical on a small machine. If you fall in this case, you can generate a product and use it as if it was a normal release.

How do I generate a Rodin product from sources?

In the project org.rodinp.platform, right-click on Rodin.platform and select export. Choose Plug-in Development > Eclipse product and click on Next type Rodin for the Root directory, and choose the Destination directory. Then click on Finish.

How to build Rodin headless?

When releasing a new version of the Rodin platform, the Rodin team builds the platform headless (i.e. using batch scripts rather than Eclipse GUI). The process used for that is described in Building Rodin Headless. Alternatively, the Rodin team has also set up a CruiseControl server for checking that builds do not break.

How to generate Rodin source plugins for a Target Platform configuration ?

For source plugins to work properly in a target platform configuration, use the Ant script explained in this page.

How do I collect debug information from the Rodin platform?

You may see the log in the console by appending -consoleLog to the rodin executable: rodin -consoleLog

You may add specific debug informations by setting specific options: rodin --debug options.file -consoleLog where
options.file
contains something like:
org.pluginname/debug = true
org.pluginname/debug/optionaldebug = true
where optionaldebug may be found in the
org.pluginname/.options
file in the rodin source repository.

How do I submit a patch?

Good practises for patch submission are described here.

How do I track memory leaks?

If you suspect that some memory isn't freed, you may find some useful directions on how to track memory leaks here.

How do I report a bug.

See the How to contribute page.

How do I save the models ?

After the separation between a file (IRodinFile) and its root (a IInternalElement), that occurred in version 0.9.2, model saving is no more achievable through internal elements. Instead, you have to save the IRodinFile.

IInternalElement element = ...
element.getRodinFile().save(...);


How do I add a new attribute to existing elements (e.g. Event-B event)?

You need to extend the following extension point org.rodinp.core.attributeTypes to declare the new attribute.

Note: There is no constraint on which element type this attribute type associated with. In principle, any attribute type can be attached to the any internal element type.

The detail steps are described in the following page Extending the Rodin Database.

How do I extend the Event-B structure editor (the Edit Tab of the Event-B editor) for editing an attribute (which I added to the Rodin DB as described here)?

You need to extend the following extension point org.eventb.ui.editorItems to declare the two different elements:

  • How the attribute is going to be displayed/edited. This is done by declaring one of the following elements: textAttribute, choiceAttribute or toggleAttribute.
  • The relationship between the attribute and internal elements. This is done by declaring an attributeRelation element. Note: In fact, this relationship declares which element allows to have this attribute, which is not something enforce when the attribute is added as described here.

The detail steps are described in the following page Extending the Structure Editor.

I have compilation errors after having checked out the org.eventb.core.seqprover plug-in, what shall I do?

Two reasons may cause compilation errors right after having checked out the org.eventb.core.seqprover plug-in:

r1. The classes are not generated properly although the project was build.
Solution : Right-click on the build-tom.xml file and select "Run As... > Ant Build". Sometimes it is also necessary to refresh: right-click the project and select "Refresh".

r2. The solution of 1 didn't work and I still have some errors in the plugin.xml file. (You will have to force the plugin.xml resource refreshing)
Solution :

  • open the plugin.xml file
  • go to the plugin.xml tab of the editor
  • insert a whitespace anywhere and save the file
  • then delete the inserted whitespace to revert your changes and save again.

The plugin.xml has been refreshed and normally all errors disappeared. If you still encounter compilation errors, please contact the Rodin developers.