Difference between revisions of "Rodin Platform 2.3 External Plug-ins"

From Event-B
Jump to: navigation, search
(Other Update Sites)
Line 13: Line 13:
 
| ||[[EMF_framework_for_Event-B|Event-B EMF framework]] || 3.5.0 ||<span style="color:#8B4513"> not available</span>|| || 24th Aug. 2011  || || Users should not need to install this framework. It will be installed automatically by other plug-ins as required.
 
| ||[[EMF_framework_for_Event-B|Event-B EMF framework]] || 3.5.0 ||<span style="color:#8B4513"> not available</span>|| || 24th Aug. 2011  || || Users should not need to install this framework. It will be installed automatically by other plug-ins as required.
 
|-
 
|-
| || [[Export to Isabelle]] || || <span style="color:#8B4513"> not available</span> || 2.x.x || || [mailto:mschmalz@inf.ethz.ch email] ||
+
| || [[Export to Isabelle]] || || <span style="color:green"> available</span> || 2.x.x || || [mailto:mschmalz@inf.ethz.ch email] ||
 
|-
 
|-
 
| [[Image:Rose.gif|30px]]||[[Rose_(Structured)_Editor|Rose]] || 1.3.0 ||<span style="color:#8B4513"> not available</span>|| || 25th Aug. 2011 || [mailto:cfs@ecs.soton.ac.uk email] ||
 
| [[Image:Rose.gif|30px]]||[[Rose_(Structured)_Editor|Rose]] || 1.3.0 ||<span style="color:#8B4513"> not available</span>|| || 25th Aug. 2011 || [mailto:cfs@ecs.soton.ac.uk email] ||
Line 29: Line 29:
 
| [[Image:Project diagram icon s.png|30px]]||[[Project_Diagram|Project Diagram]]|| 1.0.0 || <span style="color:#8B4513"> not available</span> || || || [mailto:vs2@ecs.soton.ac.uk email] ||
 
| [[Image:Project diagram icon s.png|30px]]||[[Project_Diagram|Project Diagram]]|| 1.0.0 || <span style="color:#8B4513"> not available</span> || || || [mailto:vs2@ecs.soton.ac.uk email] ||
 
|-
 
|-
| || Relevance Filter || 1.0.0 || <span style="color:#8B4513"> not available</span> || 2.x.x || || [mailto:mschmalz@inf.ethz.ch email] ||  
+
| || Relevance Filter || 1.1.1 || <span style="color:green">available</span> || 2.x.x || || [mailto:mschmalz@inf.ethz.ch email] ||  
 
|-
 
|-
 
| || [[Theory Plug-in| Theory Plug-in]] ||v1.0 ||<span style="color:#8B4513"> not available</span>||  || 8th July 2011|| [mailto:im06r@ecs.soton.ac.uk email] || Compatible with Rodin 2.2 only.
 
| || [[Theory Plug-in| Theory Plug-in]] ||v1.0 ||<span style="color:#8B4513"> not available</span>||  || 8th July 2011|| [mailto:im06r@ecs.soton.ac.uk email] || Compatible with Rodin 2.2 only.

Revision as of 08:20, 3 October 2011


Rodin Update Site

Plug-in name Version Status MCV* Release Date Contact Additional info
Umlb32.gif UML-B 2.2.0 not available 9th Feb. 2011 email
UML-B Statemachine Animation 1.1.0 not available 15th Feb. 2011 email Compatible with UML-B 2.2 and ProB 2.1.
Event-B EMF framework 3.5.0 not available 24th Aug. 2011 Users should not need to install this framework. It will be installed automatically by other plug-ins as required.
Export to Isabelle available 2.x.x email
Error creating thumbnail: Unable to save thumbnail to destination
Rose 1.3.0 not available 25th Aug. 2011 email
Records 1.0.1 not available email This release includes EMF and Refactory support for records.
Teamwork not available
Shared Event Composition 1.4.0 not available 29th June 2011 email Compatible with Rodin 2.2.x. When project or machine is changed in the included section, the modification is propagated for the combined events.
Refactory 1.2.0 not available 29th June 2011 email Version compatible with Rodin 2.2.x. More accurate monitor progress bar. Optimised rewriting of freeIdentifiers when renaming variables and constants. Added an additional wizard step corresponding to the indexer update (avoids the platform to hang while waiting for the indexer to update).
DecompositionPlug-in logo.png Decomposition 1.2.1 not available 29th June 2011 email Compatible with Rodin 2.2.x. Optimisation: parameters not used in a decomposed event are not created at all.
Error creating thumbnail: Unable to save thumbnail to destination
Project Diagram 1.0.0 not available email
Relevance Filter 1.1.1 available 2.x.x email
Theory Plug-in v1.0 not available 8th July 2011 email Compatible with Rodin 2.2 only.
Code Generation Feature 0.1.5 not available 17th May 2011 email
Logo rodin editor 200px.png Rodin Editor 0.5.0 not available 2.2.x 13th July 2011 Nicolas Beauger or Thomas Muller

B Method Update Site

Plug-in name Version Status MCV* Release Date Contact Additional info
Atelier-B provers 1.2.2 not available 2.2.x 17th Feb. 2011

Other Update Sites

Plug-in name Version Status MCV* Release Date Contact Additional info
AnimB.png AnimB available Christophe Métayer Use the update site http://www.animb.org/updatesite
Camille not available Michael Jastram Use the Camille update site. http://www.stups.uni-duesseldorf.de/camille_updates
Mlogo big.png Modularisation not available 2.x.x email Use the update site http://www.iliasov.org/modplugin
Group refinement not available 2.x.x email Use the update site http://iliasov.org/refplugin
Flows/Use case extension not available 2.x.x email Use the update site http://iliasov.org/usecase
Prob eventb wiki logo.png ProB 2.2.4 available 2.3.x 2nd Oct. 2011 Use the ProB update site. http://www.stups.uni-duesseldorf.de/prob_updates
The Plug-in includes BMotion Studio
ProR logo.png ProR 8.0.1 not available 2.x.x 16th May 2011 Michael Jastram Update site: http://update.pror.org
Project web site: http://pror.org
Error creating thumbnail: Unable to save thumbnail to destination
MBT plugin 1.0 not available 2.2.x 8th of July 2011 Alin Stefanescu Use the update site http://fmi.upit.ro/mbt_plugin
Mode/FT Views 1.0.2 not available 2.2.x 4th July 2011 Ilya Lopatkin Update site: http://rodinmodeftview.sourceforge.net/
Transformation patterns 1.0 not available 2.2.x 4th July 2011 Ilya Lopatkin Update site: http://rodinmodeftview.sourceforge.net/

*MCV stands for the Rodin's Maximum Compatible Version

Known plug-in incompatibilities

It unfortunately exists some incompatibilities between plug-ins. This list might be non exhaustive and is updated accorded to user experiences. If you encounter some conflict while installing or using plug-ins, please send a mail to the Rodin User List or feel free to complete the following table.

Plug-in name Incompatible with